Il tuo indirizzo IP è 162.158.62.126     

Inter-VLAN routing: instradamento tra VLAN

Scritto da Alessio Carta il . Inserito in CCNA . Visite: 19921

Per inter-VLAN routing si intende l’inoltro di pacchetti tra host appartenenti a VLAN diverse, e quindi appartenenti a reti separate che necessitano di un router per comunicare tra loro. Il concetto è che per far comunicare VLAN distinte, tutte devono avere un gateway di riferimento che consenta il routing: in sostanza occorre un’interfaccia del router per ogni VLAN.

Per aggirare l’ovvio problema di avere tante interfacce fisiche quante sono le VLAN da mettere in comunicazione, si utilizzano le sub-interfaces, ossia sotto-interfacce virtuali delle interfacce fisiche. Nell’immagine sottostante, si può vedere come l’interfaccia fisica fa0/0 sia stata suddivisa in 3 sub-interfaces, fa0/0.1, fa0/0.15, fa0/0.35. Nella forma di scrittura utilizzata, il valore dopo il punto indica dunque la sotto-interfaccia: convenzionalmente questo numero è uguale a quello della VLAN.

Ogni sub-interface deve appartenere ad una VLAN distinta. Per il trasporto di più VLAN sullo stesso link, la porta dello switch collegata all’interfaccia fisica del router deve essere configurata in trunk 802.1Q. Perché tutto funzioni, anche le sub-interfaces devono essere configurate con l’encapsulation 802.1Q. La configurazione del router in questi termini è spesso conosciuta con il nome di router-on-a-stick.

 

Creazione di una sub-interface

Prima di tutto è necessario che l’interfaccia fisica principale sia attiva e priva di indirizzo IP:

Router(config)#interface interfaccia
Router(config-if)#no ip address
Router(config-if)#no shutdown

A questo punto si può creare la prima sub-interface. La sua creazione si ottiene implicitamente entrando nella sua configurazione. Si imposta poi l’encapsulation 802.1Q. Importante: per convenzione il numero della sub-interface è uguale a quello della VLAN.

Router(config)#interface interfaccia.sotto-interfaccia
Router(config-subif)#encapsulation dot1q VLAN_id

Per ogni VLAN, è necessaria una sub-interface con indirizzo IP e maschera di rete:

Router(config-subif)#ip address indirizzo_ip subnet_mask

Esempio:

Router(config)#interface fa0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fa0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.248

 

Configurazione del trunk sullo switch

Switch(config)#interface interfaccia
Switch(config-if)#switchport mode trunk

 

 

Aggiungi commento


Codice di sicurezza
Aggiorna

Utilizzando questo sito accetti l'uso di cookie per analisi, contenuti personalizzati e pubblicità mirata (tramite Google AdSense). Clicca qui per maggiori informazioni