Il tuo indirizzo IP è 162.158.78.211     

Configurazione VLAN su switch Cisco

Scritto da Alessio Carta il . Inserito in CCNA . Visite: 41280

Per definizione, le VLAN rappresentano un metodo per segmentare un dominio di broadcast in più domini di dimensione ridotta. A livello 2, ogni VLAN contiene solo il traffico dei dispositivi appartenenti a quella VLAN.

Per un approfondimento dei concetti teorici relativi alle VLAN, far riferimento all'articolo VLAN - Virtual Lan.

Affinchè due VLAN comunichino tra di loro, deve esistere un router che metta in comunicazione le due VLAN, ovvero le due subnet relative alle due VLAN. L'instradamento tra VLAN è conosciuto come Inter-VLAN routing.

 

Creazione di una VLAN

In maniera predefinita, tutte le porte fanno inizialmente parte della VLAN1.

Switch(config)#vlan numero-VLAN
Switch(config-vlan)#name nome-VLAN

Esempio:
Switch(config)#vlan 30
Switch(config-vlan)#name Amministrazione

 

Assegnare una porta ad una VLAN

Switch(config)#interface interfaccia
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan numero-VLAN

Esempio:
Switch(config)#interface fa0/12
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30

Il comando "switchport mode access" forza una porta nella modalità di accesso, di conseguenza il traffico non viene taggato. Ricordiamo che le porte di accesso (access port) sono quelle porte che privano il frame ethernet del tag VLAN consegnandolo agli host. Gli host infatti non sono a conoscenza delle VLAN!

 

Impostazione del trunk

Switch(config)#interface interfaccia
Switch(config-if)#switchport mode trunk

Le porte di trunk sono usate per gli uplink tra due switch o tra switch e router. Il trunk è quindi un link che permette il trasporto di frame appartenenti a VLAN diverse. A differenza delle Access Port, le porte di trunk non privano il frame ethernet del tag VLAN.

 

Impostare le VLAN che hanno accesso al collegamento trunk

Switch(config-if)#switchport trunk allowed VLAN

Se il comando non viene utilizzato, in maniera predefinita tutte le VLAN possono transitare sul trunk.

 

Assegnare un range di porte ad una VLAN

Switch(config)#interface range interfaccia N/inizio_range - fine_range
Switch(config-if)#switchport access vlan numero-VLAN

Esempio:
Switch(config)#interface range fa0/13-18
Switch(config-if)#switchport access vlan 30

 

Visualizzare una lista dettagliata delle VLAN presenti

Switch#show vlan

Il comando visualizza inoltre le statistiche STP per ogni VLAN

 

Visualizzare un sommario delle VLAN presenti

Switch#show vlan brief

 

Visualizzare le informazioni su una VLAN specifica

Switch#show vlan id numero-VLAN

Commenti  

# push up bra enamor 2017-06-01 03:07
Great article over again! Thanks;)

Visit my web-site :: push up bra enamor: banzai816.typepad.com/.../...
Rispondi

Aggiungi commento


Codice di sicurezza
Aggiorna

Utilizzando questo sito accetti l'uso di cookie per analisi, contenuti personalizzati e pubblicità mirata (tramite Google AdSense). Clicca qui per maggiori informazioni