Il tuo indirizzo IP è 162.158.62.246     

Configurazione ADSL Tiscali su router Cisco 860 Series ISRs

Scritto da Alessio Carta il . Inserito in CCNA . Visite: 5612

In questo articolo spieghiamo come configurare un router Cisco serie 860 per un’ADSL Tiscali. In particolare la configurazione fa riferimento ad un Cisco 867VAE, che supporta gli standard ADSL  1/2/2+ e VDSL2. Poiché questo router difficilmente sarà utilizzato in ambiente casalinghi, diamo per scontato l’uso di indirizzi IP pubblici statici.

 Le connessioni ADSL Tiscali prevedono i seguenti parametri:

  • Protocollo PPP over ATM (RCF 2364)
  • Encapsulation   VC-Multiplexing (VC-MUX)
  • VPI 8
  • VCI 35

 Gli IP statici utilizzati nell’esempio successivo fanno parte della subnet pubblica 217.133.128.16/29, da cui si ricava:  

  • subnet mask 255.255.255.248
  • primo ip utile: 217.133.128.17
  • ultimo IP utile: 217.133.128.22

Lo schema rappresentativo è il seguente:

cisco adsl tiscali

Lato interno (1), assegneremo l’IP 217.133.128.17 al nostro router e il 217.133.128.18 al firewall. Il router non farà NAT, operazione che invece sarà eseguita dal firewall per consentire la navigazione ai dispositivi della rete locale. Lato esterno (2), utilizzeremo l’interfaccia DSL.

La configurazione è la seguente (sono riportate solo le righe legate al buon funzionamento della connessione in oggetto):

hostname tiscali_gw
wan mode dsl
!
no ip domain lookup
ip domain name netsetup.local
controller VDSL 0
!
interface ATM0
  no ip address
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  ip address dhcp
  pvc 8/35
   encapsulation aal5mux ppp dialer
   dialer pool-member 1
!
interface Ethernet0
  no ip address
  shutdown
!
interface FastEthernet0
  no ip address
!
interface FastEthernet1
  no ip address
!
interface FastEthernet2
  no ip address
!
interface FastEthernet3
  no ip address
!
interface GigabitEthernet0
  no ip address
  shutdown
  duplex auto
  speed auto
!
interface Vlan1
  ip address 217.133.128.17 255.255.255.248
!
interface Dialer0
  ip address negotiated
  ip mtu 1492
  encapsulation ppp
  dialer pool 1
  dialer-group 1
  ppp authentication chap callin
  ppp chap hostname Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
  ppp chap password 7 abcefghi
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
dialer-list 1 protocol ip permit
!
End

Una premessa, prima di spiegare la configurazione di sopra. Per il collegamento WAN, i router Cisco 866VAE, Cisco 867VAE, Cisco 866VAE-K9, e  Cisco 867VAE-K9 possono essere configurati per usare l’interfaccia Gigabit Ethernet oppure l’interfaccia DSL (impostazione di default). Se la WAN è impostata sull'interfaccia Gigabit Ethernet, le interfacce ATM0 e Ethernet0 risulteranno in shutdown. Se si prova il comando “no shutdown” su queste interfacce, il comando sarà rifiutato, ed il router risponderà con il messaggio “WAN interface is Ethernet”. Allo stesso modo, se la modalità WAN è DSL, l’interfaccia Gigabit Ethernet sarà in shutdown, e se si prova ad abilitarla il messaggio di avviso dirà che “WAN interface is DSL”.

Nella configurazione di sopra, abbiamo impostato la modalità WAN con interfaccia DSL:

tiscali_gw(config)# wan mode dsl

Le 4 porte FastEthernet di default fanno parte della vlan1, questo vale per la serie Cisco 860, Cisco 880 e Cisco 890. L’accesso a queste interfacce avviene quindi attraverso la VLAN 1, che configuriamo con l’indirizzo IP pubblico indicato prima.

tiscali_gw(config)#interface vlan1
tiscali_gw(config-if)#ip address 217.133.128.17 255.255.255.248

Per la modalità ADSL (ADSL 1/2/2+), è sufficiente l’impostazione automatica che si ottiene con il comando "controller vdsl 0", considerato che i DSLAM dei provider supportano tutte le modalità. In ogni caso, se si volesse specificare una modalità specifica,i comandi sono i seguenti:

tiscali_gw(config)#controller vdsl 0
tiscali_gw(config-controller)#operating mode adsl2+

Per tornare alla modalità automatica:

tiscali_gw(config-controller)#operating mode auto

La configurazione tipica per una connessione a Internet prevede la configurazione di un “Dialer” sull’interfaccia ATM. Il Dialer è un’interfaccia virtuale che deve essere associata all’interfaccia fisica ATM, e più Dialer possono essere configurati sulla stessa interfaccia ATM. Noi configureremo un solo dialer su ATM, in modalità PPPoA (PPP over ATM). Se, a livello contrattuale, si dispone di un solo IP pubblico (con necessità di NAT), l’IP può essere ottenuto automaticamente, in quanto il provider assegnerebbe quello previsto dal contratto. Nel nostro caso abbiamo una subnet da 8 IP, uno dei quali è già stato impostato sulla VLAN1 (non utilizziamo il NAT), e lasciamo comunque che il Dialer negozi automaticamente l’IP. Notare che l’MTU è stato impostato al valore massimo di 1492

tiscali_gw(config)#interface dialer 0
tiscali_gw(config -if)# description Connessione Tiscali
tiscali_gw(config -if)#ip address negotiated
tiscali_gw(config -if)#ip mtu 1492
tiscali_gw(config -if)# encapsulation ppp

Bisogna poi specificare quanti dialer pool utilizzeremo (uno solo, quello della connessione Tiscali), quindi si configura l’autenticazione. Con Tiscali, va benissimo CHAP.

tiscali_gw(config -if)# dialer pool 1
tiscali_gw(config -if)# dialer-group 1
tiscali_gw(config -if)# ppp authentication chap callin
tiscali_gw(config -if)# ppp chap hostname
Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
tiscali_gw(config -if)# ppp chap password 7 1521595B50767D

Passiamo ora alla configurazione dell’interfaccia ATM. L’interfaccia ATM sarà configurata con un indirizzo IP per la connessione punto-punto ottenuto automaticamente, con un PVC definito da VPI 8 e VCI 35, e con protocollo PPPoA incapsulato VC-MUX (aal5mux ppp nel mondo Cisco).

tiscali_gw(config)#interface ATM0
tiscali_gw(config-if)#no shutdown
tiscali_gw(config-if)#ip address dhcp
tiscali_gw(config-if)#pvc 8/35
tiscali_gw(config-if-atm-vc)#encapsulation aal5mux ppp dialer

Adesso bisogna specificare un membro del dialer pool, ossia associare all'interfaccia ATM uno o più profili dialer. Noi abbiamo definito sopra il solo profilo dialer pool 1.

tiscali_gw(config-if-atm-vc)#dialer pool-member 1

Abilitiamo l’interfaccia e usciamo.

tiscali_gw(config-if-atm-vc)#no shutdown
tiscali_gw(config-if-atm-vc)#exit

In alternativa, si può specificare una sub-interface sull’interfaccia ATM.

tiscali_gw(config)#interface ATM0
tiscali_gw(config-if)#no shutdown
tiscali_gw(config-if)#interface ATM0.1 point-to-point
tiscali_gw(config-subif)#ip address dhcp
tiscali_gw(config-subif)#pvc 8/35
tiscali_gw(config-if-atm-vc)# encapsulation aal5mux ppp dialer
tiscali_gw(config-if-atm-vc)#dialer pool-member 1
tiscali_gw(config-if-atm-vc)#no shutdown

Ora è necessario creare una “dialer list” a cui associare il dial group 1 definito in precedenza. In questo modo i pacchetti sono inoltrati sull’interfaccia associata al diale group 1.

Router(config)# dialer-list 1 protocol ip permit

Per consentire la connessione verso l’esterno è necessaria un default gateway. Specifichiamo quindi una una “default route” che consenta al traffico di uscire tramite l’interfaccia dialer 0.

tiscali_gw(config)#ip route 0.0.0.0 0.0.0.0 dialer 0

Per verificare lo stato della connessione e la configurazione ADSL, si usano i comandi seguenti:

  1. show dsl interface atm0
  2. show controller vdsl 0

 

Aggiungi commento


Codice di sicurezza
Aggiorna

Utilizzando questo sito accetti l'uso di cookie per analisi, contenuti personalizzati e pubblicità mirata (tramite Google AdSense). Clicca qui per maggiori informazioni